Blob Blame History Raw
# Generated by rust2rpm 18
# * files required by tests are not included in published crates:
#   https://github.com/PistonDevelopers/image-gif/issues/51
%bcond_with check
%global debug_package %{nil}

%global crate gif

Name:           rust-%{crate}
Version:        0.11.3
Release:        %autorelease
Summary:        GIF de- and encoder

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/gif
Source:         %{crates_source}
# Initial patched metadata
# * drop unused benchmark-only criterion dev-dependency to speed up builds
Patch0:         gif-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
GIF de- and encoder.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md Changes.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+raii_no_panic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+raii_no_panic-devel %{_description}

This package contains library source intended for building other packages
which use "raii_no_panic" feature of "%{crate}" crate.

%files       -n %{name}+raii_no_panic-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog