Blob Blame History Raw
# Generated by rust2rpm 9
%bcond_with check
%global debug_package %{nil}

%global crate h2

Name:           rust-%{crate}
Version:        0.1.23
Release:        1%{?dist}
Summary:        HTTP/2.0 client and server

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/h2
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(byteorder/default) >= 1.0.0 with crate(byteorder/default) < 2.0.0)
BuildRequires:  (crate(bytes/default) >= 0.4.7 with crate(bytes/default) < 0.5.0)
BuildRequires:  (crate(fnv/default) >= 1.0.5 with crate(fnv/default) < 2.0.0)
BuildRequires:  (crate(futures/default) >= 0.1.0 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(http/default) >= 0.1.8 with crate(http/default) < 0.2.0)
BuildRequires:  (crate(indexmap/default) >= 1.0.0 with crate(indexmap/default) < 2.0.0)
BuildRequires:  (crate(log/default) >= 0.4.1 with crate(log/default) < 0.5.0)
BuildRequires:  (crate(slab/default) >= 0.4.0 with crate(slab/default) < 0.5.0)
BuildRequires:  (crate(string/default) >= 0.2.0 with crate(string/default) < 0.3.0)
BuildRequires:  (crate(tokio-io/default) >= 0.1.4 with crate(tokio-io/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(env_logger) >= 0.5.3 with crate(env_logger) < 0.6.0)
BuildRequires:  (crate(hex/default) >= 0.2.0 with crate(hex/default) < 0.3.0)
BuildRequires:  (crate(quickcheck) >= 0.4.1 with crate(quickcheck) < 0.5.0)
BuildRequires:  (crate(rand/default) >= 0.3.15 with crate(rand/default) < 0.4.0)
BuildRequires:  (crate(rustls/default) >= 0.12.0 with crate(rustls/default) < 0.13.0)
BuildRequires:  (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires:  (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
BuildRequires:  (crate(tokio-rustls/default) >= 0.5.0 with crate(tokio-rustls/default) < 0.6.0)
BuildRequires:  (crate(tokio/default) >= 0.1.8 with crate(tokio/default) < 0.2.0)
BuildRequires:  (crate(walkdir/default) >= 1.0.0 with crate(walkdir/default) < 2.0.0)
BuildRequires:  (crate(webpki-roots/default) >= 0.14.0 with crate(webpki-roots/default) < 0.15.0)
BuildRequires:  (crate(webpki/default) >= 0.18.0 with crate(webpki/default) < 0.19.0)
%endif

%global _description %{expand:
HTTP/2.0 client and server.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+unstable-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-devel %{_description}

This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.

%files       -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Jun 05 17:48:13 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.23-1
- Update to 0.1.23

* Mon Jun 03 2019 Josh Stone <jistone@redhat.com> - 0.1.22-1
- Update to 0.1.22

* Fri May 31 16:01:11 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.21-1
- Update to 0.1.21

* Wed Apr 10 07:39:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.18-1
- Update to 0.1.18

* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.17-1
- Update to 0.1.17

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Thu Jan 24 2019 Josh Stone <jistone@redhat.com> - 0.1.16-1
- Update to 0.1.16

* Mon Jan 14 2019 Josh Stone <jistone@redhat.com> - 0.1.15-1
- Update to 0.1.15

* Thu Dec 06 2018 Josh Stone <jistone@redhat.com> - 0.1.14-1
- Update to 0.1.14

* Mon Nov 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.13-2
- Adapt to new packaging

* Mon Oct 22 2018 Josh Stone <jistone@redhat.com> - 0.1.13-1
- Update to 0.1.13

* Thu Aug 09 2018 Josh Stone <jistone@redhat.com> - 0.1.12-1
- Update to 0.1.12

* Sat Aug 04 2018 Josh Stone <jistone@redhat.com> - 0.1.11-1
- Update to 0.1.11

* Wed Jul 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.10-1
- Initial package