Blob Blame History Raw
# Generated by rust2rpm 18
%bcond_without check
%global debug_package %{nil}

%global crate hashbrown

Name:           rust-%{crate}0.9
Version:        0.9.1
Release:        %autorelease
Summary:        Rust port of Google's SwissTable hash map

# Upstream license specification: Apache-2.0/MIT
License:        ASL 2.0 or MIT
URL:            https://crates.io/crates/hashbrown
Source:         %{crates_source}
# Initial patched metadata
# * drop dependencies on compiler internals
# * drop nightly-only features
# * relax rustc-hash dev-dependency
Patch0:         hashbrown-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Rust port of Google's SwissTable hash map.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+ahash-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ahash-devel %{_description}

This package contains library source intended for building other packages
which use "ahash" feature of "%{crate}" crate.

%files       -n %{name}+ahash-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+ahash-compile-time-rng-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ahash-compile-time-rng-devel %{_description}

This package contains library source intended for building other packages
which use "ahash-compile-time-rng" feature of "%{crate}" crate.

%files       -n %{name}+ahash-compile-time-rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+inline-more-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+inline-more-devel %{_description}

This package contains library source intended for building other packages
which use "inline-more" feature of "%{crate}" crate.

%files       -n %{name}+inline-more-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+raw-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+raw-devel %{_description}

This package contains library source intended for building other packages
which use "raw" feature of "%{crate}" crate.

%files       -n %{name}+raw-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+rayon-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rayon-devel %{_description}

This package contains library source intended for building other packages
which use "rayon" feature of "%{crate}" crate.

%files       -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog