Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check

%global crate lscolors

Name:           rust-lscolors
Version:        0.15.0
Release:        %autorelease
Summary:        Colorize paths using the LS_COLORS environment variable

# Upstream license specification: MIT/Apache-2.0
License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/lscolors
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * turn off stripping, needed for debug packages
Patch:          lscolors-fix-metadata.diff

BuildRequires:  rust-packaging >= 23

%global _description %{expand:
Colorize paths using the LS_COLORS environment variable.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# MIT
# MIT OR Apache-2.0
License:        MIT AND (MIT OR Apache-2.0)
# LICENSE.dependencies contains a full license breakdown

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE-APACHE
%license LICENSE-MIT
%license LICENSE.dependencies
%doc README.md
%{_bindir}/lscolors

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ansi_term-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ansi_term-devel %{_description}

This package contains library source intended for building other packages which
use the "ansi_term" feature of the "%{crate}" crate.

%files       -n %{name}+ansi_term-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+crossterm-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+crossterm-devel %{_description}

This package contains library source intended for building other packages which
use the "crossterm" feature of the "%{crate}" crate.

%files       -n %{name}+crossterm-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+nu-ansi-term-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+nu-ansi-term-devel %{_description}

This package contains library source intended for building other packages which
use the "nu-ansi-term" feature of the "%{crate}" crate.

%files       -n %{name}+nu-ansi-term-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires -f nu-ansi-term

%build
%cargo_build -f nu-ansi-term
%{cargo_license_summary -f nu-ansi-term}
%{cargo_license -f nu-ansi-term} > LICENSE.dependencies

%install
%cargo_install -f nu-ansi-term

%if %{with check}
%check
%cargo_test -f nu-ansi-term
%endif

%changelog
%autochangelog