Blob Blame History Raw
# Generated by rust2rpm 22
%bcond_without check

%global crate lsd

Name:           rust-lsd
Version:        0.22.0
Release:        %autorelease
Summary:        Ls command with a lot of pretty colors and some other stuff

License:        Apache-2.0
URL:            https://crates.io/crates/lsd
Source:         %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch:          lsd-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * normalize weird glob-style dependencies to SemVer compatible format
# * bump assert_cmd from 1 to 2
# * bump chrono-humanize from 0.1 to 0.2
# * bump crossterm from 0.21 to 0.22
# * bump lscolors from 0.9 to 0.10
Patch:          lsd-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Ls command with a lot of pretty colors and some other stuff.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%doc CHANGELOG.md
%doc README.md
%{_bindir}/lsd

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# * skip tests that rely on files that are not included in published crates
# * skip a broken test (our "cargo test" CLI arguments somehow leak into it)
%cargo_test -- -- --skip color::theme::tests --skip test_symlink_arrow_from_args_none
%endif

%changelog
%autochangelog