Blob Blame History Raw
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}

%global crate matrixmultiply

Name:           rust-%{crate}
Version:        0.2.2
Release:        1%{?dist}
Summary:        General matrix multiplication for f32 and f64 matrices

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/matrixmultiply
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(rawpointer/default) >= 0.1.0 with crate(rawpointer/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(bencher/default) >= 0.1.2 with crate(bencher/default) < 0.2.0)
BuildRequires:  (crate(itertools/default) >= 0.7.11 with crate(itertools/default) < 0.8.0)
%endif

%global _description \
General matrix multiplication for f32 and f64 matrices. Operates on matrices\
with general layout (they can use arbitrary row and column stride). Detects and\
uses AVX or SSE2 on x86 platforms transparently for higher performance. Uses a\
microkernel strategy, so that the implementation is easy to parallelize and\
optimize.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.rst
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2

* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.15-3
- Run tests in infrastructure

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.15-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Oct 30 2018 Josh Stone <jistone@redhat.com> - 0.1.15-1
- Update to 0.1.15

* Mon Sep 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.14-1
- Initial package