Blob Blame History Raw
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}

%global crate nom

Name:           rust-%{crate}
Version:        4.2.2
Release:        1%{?dist}
Summary:        Byte-oriented, zero-copy, parser combinators library

License:        MIT
URL:            https://crates.io/crates/nom
Source:         %{crates_source}
# Initial patched metadata
# * the benches are not included in the package
Patch0:         nom-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
BuildRequires:  (crate(memchr/use_std) >= 2.0.0 with crate(memchr/use_std) < 3.0.0)
BuildRequires:  (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
BuildRequires:  (crate(version_check/default) >= 0.1.0 with crate(version_check/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(criterion/default) >= 0.2.0 with crate(criterion/default) < 0.3.0)
BuildRequires:  (crate(jemallocator/default) >= 0.1.0 with crate(jemallocator/default) < 0.2.0)
%endif

%global _description \
A byte-oriented, zero-copy, parser combinators library.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alloc-devel %{_description}

This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.

%files       -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+lazy_static-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lazy_static-devel %{_description}

This package contains library source intended for building other packages
which use "lazy_static" feature of "%{crate}" crate.

%files       -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+regex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+regex-devel %{_description}

This package contains library source intended for building other packages
which use "regex" feature of "%{crate}" crate.

%files       -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+regexp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+regexp-devel %{_description}

This package contains library source intended for building other packages
which use "regexp" feature of "%{crate}" crate.

%files       -n %{name}+regexp-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+regexp_macros-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+regexp_macros-devel %{_description}

This package contains library source intended for building other packages
which use "regexp_macros" feature of "%{crate}" crate.

%files       -n %{name}+regexp_macros-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+verbose-errors-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+verbose-errors-devel %{_description}

This package contains library source intended for building other packages
which use "verbose-errors" feature of "%{crate}" crate.

%files       -n %{name}+verbose-errors-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Mon Mar 04 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.2.2-1
- Update to 4.2.2

* Thu Feb 28 2019 Josh Stone <jistone@redhat.com> - 4.2.1-1
- Update to 4.2.1

* Mon Feb 11 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.2.0-3
- Run tests in infrastructure

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Jan 29 2019 Josh Stone <jistone@redhat.com> - 4.2.0-1
- Update to 4.2.0

* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.1.1-2
- Adapt to new packaging

* Mon Oct 22 2018 Josh Stone <jistone@redhat.com> - 4.1.1-1
- Update to 4.1.1

* Sat Oct 06 2018 Josh Stone <jistone@redhat.com> - 4.1.0-1
- Update to 4.1.0

* Fri Sep 07 2018 Josh Stone <jistone@redhat.com> - 4.0.0-3
- Fix duplicate macro export

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-1
- Update to 4.0.0

* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-5
- Bump regex to 1

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-3
- Rebuild for rust-packaging v5

* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-2
- Bump lazy_static to 1

* Sat Nov 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-1
- Initial package