Blob Blame History Raw
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate notify

Name:           rust-notify
Version:        6.1.1
Release:        %autorelease
Summary:        Cross-platform filesystem notification library

License:        CC0-1.0
URL:            https://crates.io/crates/notify
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          notify-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove macOS-specific features
Patch:          notify-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Cross-platform filesystem notification library.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-CC0
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+crossbeam-channel-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+crossbeam-channel-devel %{_description}

This package contains library source intended for building other packages which
use the "crossbeam-channel" feature of the "%{crate}" crate.

%files       -n %{name}+crossbeam-channel-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+manual_tests-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+manual_tests-devel %{_description}

This package contains library source intended for building other packages which
use the "manual_tests" feature of the "%{crate}" crate.

%files       -n %{name}+manual_tests-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+timing_tests-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+timing_tests-devel %{_description}

This package contains library source intended for building other packages which
use the "timing_tests" feature of the "%{crate}" crate.

%files       -n %{name}+timing_tests-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog