Blob Blame History Raw
# Generated by rust2rpm 26
# * missing dev-dependencies: enterpolation ^0.2
%bcond_with check
%global debug_package %{nil}

%global crate palette

Name:           rust-palette
Version:        0.7.5
Release:        %autorelease
Summary:        Convert and manage colors with a focus on correctness, flexibility and ease of use

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/palette
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Convert and manage colors with a focus on correctness, flexibility and
ease of use.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alloc-devel %{_description}

This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.

%files       -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+approx-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+approx-devel %{_description}

This package contains library source intended for building other packages which
use the "approx" feature of the "%{crate}" crate.

%files       -n %{name}+approx-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bytemuck-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bytemuck-devel %{_description}

This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.

%files       -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+find-crate-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+find-crate-devel %{_description}

This package contains library source intended for building other packages which
use the "find-crate" feature of the "%{crate}" crate.

%files       -n %{name}+find-crate-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libm-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libm-devel %{_description}

This package contains library source intended for building other packages which
use the "libm" feature of the "%{crate}" crate.

%files       -n %{name}+libm-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+named-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+named-devel %{_description}

This package contains library source intended for building other packages which
use the "named" feature of the "%{crate}" crate.

%files       -n %{name}+named-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+named_from_str-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+named_from_str-devel %{_description}

This package contains library source intended for building other packages which
use the "named_from_str" feature of the "%{crate}" crate.

%files       -n %{name}+named_from_str-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+phf-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+phf-devel %{_description}

This package contains library source intended for building other packages which
use the "phf" feature of the "%{crate}" crate.

%files       -n %{name}+phf-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rand-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rand-devel %{_description}

This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.

%files       -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+random-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+random-devel %{_description}

This package contains library source intended for building other packages which
use the "random" feature of the "%{crate}" crate.

%files       -n %{name}+random-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serializing-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serializing-devel %{_description}

This package contains library source intended for building other packages which
use the "serializing" feature of the "%{crate}" crate.

%files       -n %{name}+serializing-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wide-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wide-devel %{_description}

This package contains library source intended for building other packages which
use the "wide" feature of the "%{crate}" crate.

%files       -n %{name}+wide-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog