Blob Blame History Raw
# Generated by rust2rpm 16
%bcond_without check
%global debug_package %{nil}

%global crate python3-sys

Name:           rust-%{crate}
Version:        0.5.2
Release:        1%{?dist}
Summary:        FFI Declarations for Python 3

# Upstream license specification: Python-2.0
License:        Python

URL:            https://crates.io/crates/python3-sys
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
FFI Declarations for Python 3.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+extension-module-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+extension-module-devel %{_description}

This package contains library source intended for building other packages
which use "extension-module" feature of "%{crate}" crate.

%files       -n %{name}+extension-module-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+link-mode-default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+link-mode-default-devel %{_description}

This package contains library source intended for building other packages
which use "link-mode-default" feature of "%{crate}" crate.

%files       -n %{name}+link-mode-default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+link-mode-unresolved-static-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+link-mode-unresolved-static-devel %{_description}

This package contains library source intended for building other packages
which use "link-mode-unresolved-static" feature of "%{crate}" crate.

%files       -n %{name}+link-mode-unresolved-static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+pep-384-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pep-384-devel %{_description}

This package contains library source intended for building other packages
which use "pep-384" feature of "%{crate}" crate.

%files       -n %{name}+pep-384-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.3

%description -n %{name}+python-3-devel %{_description}

This package contains library source intended for building other packages
which use "python-3" feature of "%{crate}" crate.

%files       -n %{name}+python-3-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-4-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.4

%description -n %{name}+python-3-4-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-4" feature of "%{crate}" crate.

%files       -n %{name}+python-3-4-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-5-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.5

%description -n %{name}+python-3-5-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-5" feature of "%{crate}" crate.

%files       -n %{name}+python-3-5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-6-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.6

%description -n %{name}+python-3-6-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-6" feature of "%{crate}" crate.

%files       -n %{name}+python-3-6-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-7-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.7

%description -n %{name}+python-3-7-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-7" feature of "%{crate}" crate.

%files       -n %{name}+python-3-7-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-8-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.8

%description -n %{name}+python-3-8-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-8" feature of "%{crate}" crate.

%files       -n %{name}+python-3-8-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+python-3-9-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       python3-devel >= 3.9

%description -n %{name}+python-3-9-devel %{_description}

This package contains library source intended for building other packages
which use "python-3-9" feature of "%{crate}" crate.

%files       -n %{name}+python-3-9-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires
echo 'python3-devel >= 3.3'

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Thu Jan 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.5.2-1
- Initial package