Blob Blame History Raw
# Generated by rust2rpm 25
# * need root permission to run test
%bcond_with check
%global debug_package %{nil}

%global crate rtnetlink

Name:           rust-rtnetlink
Version:        0.14.1
Release:        %autorelease
Summary:        Manipulate linux networking resources via netlink

License:        MIT
URL:            https://crates.io/crates/rtnetlink
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Manipulate linux networking resources via netlink.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+async-global-executor-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+async-global-executor-devel %{_description}

This package contains library source intended for building other packages which
use the "async-global-executor" feature of the "%{crate}" crate.

%files       -n %{name}+async-global-executor-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+smol_socket-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+smol_socket-devel %{_description}

This package contains library source intended for building other packages which
use the "smol_socket" feature of the "%{crate}" crate.

%files       -n %{name}+smol_socket-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+test_as_root-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+test_as_root-devel %{_description}

This package contains library source intended for building other packages which
use the "test_as_root" feature of the "%{crate}" crate.

%files       -n %{name}+test_as_root-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio_socket-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio_socket-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio_socket" feature of the "%{crate}" crate.

%files       -n %{name}+tokio_socket-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog