Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate serde-xml-rs

Name:           rust-serde-xml-rs
Version:        0.4.1
Release:        %autorelease
Summary:        Xml-rs based deserializer for Serde (compatible with 0.9+)

License:        MIT
URL:            https://crates.io/crates/serde-xml-rs
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Xml-rs based deserializer for Serde (compatible with 0.9+).}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# tests using docmatic fail to compile
# https://github.com/RReverser/serde-xml-rs/issues/101
rm tests/readme.rs
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# * skip a test that fails but in the wrong way (?)
# * skip broken integration tests (simple_logger initialization fails)
%cargo_test -- --lib -- --skip test_doctype_fail
%cargo_test -- --doc -- --skip test_doctype_fail
%endif

%changelog
%autochangelog