Blob Blame History Raw
# Generated by rust2rpm 16
%bcond_without check
%global debug_package %{nil}

%global crate socket2

Name:           rust-%{crate}_0.3
Version:        0.3.19
Release:        1%{?dist}
Summary:        Utilities for handling networking sockets

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/socket2
Source:         %{crates_source}
# Initial patched metadata
# * No windows dependencies
Patch0:         socket2-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Utilities for handling networking sockets with a maximal amount of
configuration possible intended.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+pair-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pair-devel %{_description}

This package contains library source intended for building other packages
which use "pair" feature of "%{crate}" crate.

%files       -n %{name}+pair-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+reuseport-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+reuseport-devel %{_description}

This package contains library source intended for building other packages
which use "reuseport" feature of "%{crate}" crate.

%files       -n %{name}+reuseport-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+unix-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unix-devel %{_description}

This package contains library source intended for building other packages
which use "unix" feature of "%{crate}" crate.

%files       -n %{name}+unix-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# The test requires networking to be present
# https://github.com/alexcrichton/socket2-rs/issues/52
%cargo_test -- -- --skip socket::test::connect_timeout_unrouteable
%endif

%changelog
* Thu Mar 25 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.19-1
- Initial compat package for socket2 0.3.