Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate spin

Name:           rust-spin
Version:        0.9.6
Release:        %autorelease
Summary:        Spin-based synchronization primitives

License:        MIT
URL:            https://crates.io/crates/spin
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Spin-based synchronization primitives.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+barrier-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+barrier-devel %{_description}

This package contains library source intended for building other packages which
use the "barrier" feature of the "%{crate}" crate.

%files       -n %{name}+barrier-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+fair_mutex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+fair_mutex-devel %{_description}

This package contains library source intended for building other packages which
use the "fair_mutex" feature of the "%{crate}" crate.

%files       -n %{name}+fair_mutex-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+lazy-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lazy-devel %{_description}

This package contains library source intended for building other packages which
use the "lazy" feature of the "%{crate}" crate.

%files       -n %{name}+lazy-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+lock_api-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lock_api-devel %{_description}

This package contains library source intended for building other packages which
use the "lock_api" feature of the "%{crate}" crate.

%files       -n %{name}+lock_api-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+lock_api_crate-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lock_api_crate-devel %{_description}

This package contains library source intended for building other packages which
use the "lock_api_crate" feature of the "%{crate}" crate.

%files       -n %{name}+lock_api_crate-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+mutex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+mutex-devel %{_description}

This package contains library source intended for building other packages which
use the "mutex" feature of the "%{crate}" crate.

%files       -n %{name}+mutex-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+once-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+once-devel %{_description}

This package contains library source intended for building other packages which
use the "once" feature of the "%{crate}" crate.

%files       -n %{name}+once-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+portable-atomic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+portable-atomic-devel %{_description}

This package contains library source intended for building other packages which
use the "portable-atomic" feature of the "%{crate}" crate.

%files       -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+portable_atomic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+portable_atomic-devel %{_description}

This package contains library source intended for building other packages which
use the "portable_atomic" feature of the "%{crate}" crate.

%files       -n %{name}+portable_atomic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rwlock-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rwlock-devel %{_description}

This package contains library source intended for building other packages which
use the "rwlock" feature of the "%{crate}" crate.

%files       -n %{name}+rwlock-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+spin_mutex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+spin_mutex-devel %{_description}

This package contains library source intended for building other packages which
use the "spin_mutex" feature of the "%{crate}" crate.

%files       -n %{name}+spin_mutex-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ticket_mutex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ticket_mutex-devel %{_description}

This package contains library source intended for building other packages which
use the "ticket_mutex" feature of the "%{crate}" crate.

%files       -n %{name}+ticket_mutex-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+use_ticket_mutex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+use_ticket_mutex-devel %{_description}

This package contains library source intended for building other packages which
use the "use_ticket_mutex" feature of the "%{crate}" crate.

%files       -n %{name}+use_ticket_mutex-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog