Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}

%global crate tokio-current-thread

Name:           rust-%{crate}
Version:        0.1.3
Release:        2%{?dist}
Summary:        Single threaded executor which manage many tasks concurrently

License:        MIT
URL:            https://crates.io/crates/tokio-current-thread
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(futures/default) >= 0.1.19 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(tokio-executor/default) >= 0.1.5 with crate(tokio-executor/default) < 0.2.0)

%global _description \
Single threaded executor which manage many tasks concurrently on the current\
thread.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Thu Nov 08 2018 Josh Stone <jistone@redhat.com> - 0.1.3-2
- Adapt to new packaging

* Fri Sep 28 2018 Josh Stone <jistone@redhat.com> - 0.1.3-1
- Update to 0.1.3

* Wed Aug 08 2018 Josh Stone <jistone@redhat.com> - 0.1.1-1
- Update to 0.1.1

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Fri Jun 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.0-1
- Initial package