Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate vm-memory

Name:           rust-vm-memory
Version:        0.12.0
Release:        %autorelease
Summary:        Safe abstractions for accessing the VM physical memory

License:        Apache-2.0 OR BSD-3-Clause
URL:            https://crates.io/crates/vm-memory
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * exclude files that are only useful for upstream development
Patch:          vm-memory-fix-metadata.diff

# vm-memory does not support 32 bit targets
ExcludeArch:    %{ix86}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Safe abstractions for accessing the VM physical memory.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-BSD-3-Clause
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/DESIGN.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/TODO.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+arc-swap-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+arc-swap-devel %{_description}

This package contains library source intended for building other packages which
use the "arc-swap" feature of the "%{crate}" crate.

%files       -n %{name}+arc-swap-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+backend-atomic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+backend-atomic-devel %{_description}

This package contains library source intended for building other packages which
use the "backend-atomic" feature of the "%{crate}" crate.

%files       -n %{name}+backend-atomic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+backend-bitmap-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+backend-bitmap-devel %{_description}

This package contains library source intended for building other packages which
use the "backend-bitmap" feature of the "%{crate}" crate.

%files       -n %{name}+backend-bitmap-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+backend-mmap-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+backend-mmap-devel %{_description}

This package contains library source intended for building other packages which
use the "backend-mmap" feature of the "%{crate}" crate.

%files       -n %{name}+backend-mmap-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bitflags-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bitflags-devel %{_description}

This package contains library source intended for building other packages which
use the "bitflags" feature of the "%{crate}" crate.

%files       -n %{name}+bitflags-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+vmm-sys-util-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+vmm-sys-util-devel %{_description}

This package contains library source intended for building other packages which
use the "vmm-sys-util" feature of the "%{crate}" crate.

%files       -n %{name}+vmm-sys-util-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xen-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xen-devel %{_description}

This package contains library source intended for building other packages which
use the "xen" feature of the "%{crate}" crate.

%files       -n %{name}+xen-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog