Blob Blame History Raw
# Generated by rust2rpm 18
%bcond_without check
%global debug_package %{nil}

%global crate wasmtime-types

Name:           rust-%{crate}
Version:        0.30.0
Release:        %autorelease
Summary:        WebAssembly type definitions for Cranelift

# Upstream license specification: Apache-2.0 WITH LLVM-exception
License:        ASL 2.0 with exceptions
URL:            https://crates.io/crates/wasmtime-types
Source:         %{crates_source}
# License file is not included in the crate
# Cf. https://github.com/bytecodealliance/wasmtime/pull/3382
Source1:        LICENSE

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
WebAssembly type definitions for Cranelift.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# Add LICENSE file
install -p %{SOURCE1} .
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog