Blob Blame History Raw
# Generated by rust2rpm 22
# * test suite requires both a running system and session bus
%bcond_with check
%global debug_package %{nil}

%global crate zbus

Name:           rust-zbus1
Version:        1.9.3
Release:        %autorelease
Summary:        API for D-Bus communication

License:        MIT
URL:            https://crates.io/crates/zbus
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
API for D-Bus communication.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-xml-rs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-xml-rs-devel %{_description}

This package contains library source intended for building other packages which
use the "serde-xml-rs" feature of the "%{crate}" crate.

%files       -n %{name}+serde-xml-rs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xml-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xml-devel %{_description}

This package contains library source intended for building other packages which
use the "xml" feature of the "%{crate}" crate.

%files       -n %{name}+xml-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog