Blob Blame History Raw
%define pyver %(python -c 'import sys ; print sys.version[:3]')

Summary: Xen is a virtual machine monitor
Name:    xen
Version: 2
Release: 20050124
Group:   Development/Libraries
License: GPL
URL:     http://www.sourceforge.net/projects/xen/
Source0: http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-unstable-src.tgz
# Source0: %{name}-%{version}-src.tgz
Patch0: xen-printf-warning.patch
Patch1: xen-install-nocheck.patch
Patch2: xen-misc-fixes.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: transfig libidn-devel
BuildRequires: xorg-x11-devel python-devel
Requires: bridge-utils python-twisted
Requires: python-abi = %{pyver}
ExclusiveArch: i386

%description
This package contains the Xen hypervisor and Xen tools, needed to
run virtual machines on x86 systems, together with the kernel-xen*
packages.  Information on how to use Xen can be found at the Xen
project pages.

Virtualisation can be used to run multiple versions or multiple
Linux distributions on one system, or to test untrusted applications
in a sandboxed environment.  Note that the Xen technology is still
in development, and this RPM has received extremely little testing.
Don't be surprised if this RPM eats your data, drinks your coffee
or makes fun of you in front of your friends.

%prep
%setup -q -n xen-unstable
%patch0 -p1
%patch1 -p1
%patch2 -p1

%build
CFLAGS="$RPM_OPT_FLAGS" %{__make} xen tools docs 

%install
rm -rf %{buildroot}
make prefix=%{buildroot} install-xen install-tools install-docs
mkdir -p %{buildroot}%{_localstatedir}/%{name}/xend-db/domain
mkdir -p %{buildroot}%{_localstatedir}/%{name}/xend-db/vnet

### fixing the man
install -d %{buildroot}%{_mandir}
mv %{buildroot}/usr/man/* %{buildroot}%{_mandir}

rm -f %{buildroot}%{_includedir}/%{name}/COPYING

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc COPYING ChangeLog README docs 
/boot/%{name}-syms
/boot/%{name}.gz
%{_sbindir}/device-model
%{_sbindir}/netfix
%{_sbindir}/xcs
%{_sbindir}/xcsdump
%{_sbindir}/xend
%{_sbindir}/xensv
%{_sbindir}/xfrd
%{_sbindir}/xm
%{_sbindir}/xenperf
%{_bindir}/xenperf
%{_bindir}/miniterm
%{_bindir}/xencons
%{_bindir}/xentrace
%{_bindir}/xentrace_format
%{_includedir}/*.h
%dir %{_includedir}/%{name}
%{_includedir}/%{name}/*.h
%{_includedir}/%{name}/*/*.h
%{_libdir}/libxc.so.*
%{_libdir}/libxutil.so.*
%{_libdir}/libxc.so
%{_libdir}/libxutil.so
%{_libdir}/libxutil.a
%dir %{_libdir}/python/%{name}
%{_libdir}/python/%{name}/*
%{_mandir}/man?/*.?.gz
%dir %{_localstatedir}/%{name}
%{_localstatedir}/%{name}/*
%{_sysconfdir}/init.d/xend
%{_sysconfdir}/init.d/xendomains
%dir %{_sysconfdir}/%{name}
%{_sysconfdir}/%{name}*

%changelog
* Tue Jan 25 2005 Jeremy Katz <katzj@redhat.com>
- add buildreqs on python-devel and xorg-x11-devel (strange AT nsk.no-ip.org)

* Mon Jan 24 2005 Rik van Riel <riel@redhat.com> - 2-20050124
- fix /etc/xen/scripts/network to not break with ipv6 (also sent upstream)

* Fri Jan 14 2005 Jeremy Katz <katzj@redhat.com> - 2-20050114
- update to new snap
- python-twisted is its own package now
- files are in /usr/lib/python now as well, ugh.

* Tue Jan 11 2005 Rik van Riel <riel@redhat.com>
- add segment fixup patch from xen tree
- fix %files list for python-twisted

* Mon Jan 10 2005 Rik van Riel <riel@redhat.com>
- grab newer snapshot, that does start up
- add /var/xen/xend-db/{domain,vnet} to %files section

* Thu Jan  6 2005 Rik van Riel <riel@redhat.com>
- upgrade to new snapshot of xen-unstable

* Mon Dec 13 2004 Rik van Riel <riel@redhat.com>
- build python-twisted as a subpackage
- update to latest upstream Xen snapshot

* Sun Dec  5 2004 Rik van Riel <riel@redhat.com>
- grab new Xen tarball (with wednesday's patch already included)
- transfig is a buildrequire, add it to the spec file

* Wed Dec  1 2004 Rik van Riel <riel@redhat.com>
- fix up Che's spec file a little bit
- create patch to build just Xen, not the kernels

* Wed Dec 01 2004 Che
- initial rpm release