Blob Blame History Raw
Name:           xml-security-c
Version:        1.5.1
Release:        4%{?dist}
Summary:        C++ Implementation of W3C security standards for XML

Group:          System Environment/Libraries
License:        ASL 2.0
URL:            http://santuario.apache.org/c/
Source:         http://santuario.apache.org/dist/c-library/%{name}-%{version}.tar.gz
Patch0:		xml-security-c-1.5.1-CVE-2011-2516.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildRequires:  xerces-c-devel xalan-c-devel openssl-devel
BuildRequires:  pkgconfig

%description
The xml-security-c library is a C++ implementation of the XML Digital Signature
specification. The library makes use of the Apache XML project's Xerces-C XML
Parser and Xalan-C XSLT processor. The latter is used for processing XPath and
XSLT transforms.


%package        devel
Summary:        Development files for xml-security-c
Group:          Development/Libraries
Requires:       %{name} = %{version}-%{release}
Requires:       xerces-c-devel xalan-c-devel openssl-devel
# There are a number of headers that can use NSS if HAVE_NSS is set to 1
# Current build does not set it (configure does not even check for NSS)
# so we do not include this dependency for now.
# Requires:       nss-devel

%description devel
This package provides development files for xml-security-c, a C++ library for
XML Digital Signatures.


%prep
%setup -q
%patch0 -p1
# Remove bogus "-O2" from CXXFLAGS to avoid overriding RPM_OPT_FLAGS.
sed -i -e 's/-O2 -DNDEBUG/-DNDEBUG/g' configure

%build
%configure --disable-static
make %{?_smp_mflags}

%check
# Verify that what was compiled actually works.
./bin/xtest

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT CPPROG="cp -p"

# We do not ship .la files.
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la

# Do not ship library test utilities. These are only needed for
# xml-security-c developers and they should have the whole source anyway.
rm -rf $RPM_BUILD_ROOT%{_bindir}

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%{_libdir}/libxml-security-c.so.*


%files devel
%defattr(-,root,root,-)
%{_includedir}/xsec
%{_libdir}/libxml-security-c.so

# Upstream does not provide any docs (yet!)
# %doc CHANGELOG.txt

%changelog
* Fri Jul 08 2011 Antti Andreimann <Antti.Andreimann@mail.ee> - 1.5.1-4
- Backported a patch to fix CVE-2011-2516 (#719698)

* Sat Feb 06 2010 steve.traylen@cern.ch - 1.5.1-3
- Rebuild for xerces 2 to 3 .so bump

* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.5.1-2
- rebuilt with new openssl

* Tue Jul 28 2009 Antti Andreimann <Antti.Andreimann@mail.ee> 1.5.1-1
- New upstream relase (#513078)
- Fixes CVE-2009-0217 (#511915)

* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Mon Jul 06 2009 Antti Andreimann <Antti.Andreimann@mail.ee> - 1.5.0-1
- New upstream release

* Tue Apr 28 2009 Antti Andreimann <Antti.Andreimann@mail.ee> - 1.4.0-2
- Execute sed magic against configure instead of configure.ac to 
  avoid calling autotools
- Removed build dependency on autotools.
- Do not ship test binaries (not needed for end-users)
- Added proper dependencies for devel sub-package
- Added CPPROG="cp -p" to preserve header file timestamps.

* Mon Mar 30 2009 Antti Andreimann <Antti.Andreimann@mail.ee> - 1.4.0-1
- Initial RPM release.