Blob Blame History Raw
%define audacious_input_plugin_dir %(pkg-config --variable=input_plugin_dir audacious)
%define xmms_input_plugin_dir %(xmms-config --input-plugin-dir)

%global aud_plugin_api %(grep '[ ]*#define[ ]*_AUD_PLUGIN_VERSION[ ]\\+' %{_includedir}/audacious/plugin.h 2>/dev/null | sed 's!.*_AUD_PLUGIN_VERSION[ ]*\\([0-9]\\+\\).*!\\1!')
%if 0%{aud_plugin_api} > 0
%global aud_plugin_dep Requires: audacious(plugin-api)%{?_isa} = %{aud_plugin_api}
%endif

Name: xmp
Version: 3.4.0
Release: 8%{?dist}
Summary: A multi-format module player
Group: Applications/Multimedia
#Source: http://downloads.sourceforge.net/sourceforge/xmp/xmp-%{version}.tar.gz
#same source as above, with docs/formats/gdm.txt removed
Source: %{name}-%{version}-free.tar.gz
# run this to get the above tarball
Source1: mktarball.sh
License: GPLv2+
URL: http://xmp.sourceforge.net/
Buildrequires: alsa-lib-devel
Buildrequires: audacious-devel
BuildRequires: pulseaudio-libs-devel
Buildrequires: xmms-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)

# port to Audacious 3.1 Preferences API, albeit without connecting
# any GUI elements with config section/name pairs directly
Patch0: xmp-3.4.0-audacious-3.1.patch
Patch1: xmp-3.4.0-audacious-3.2.patch
# fix untimely g_free / will be reported to xmp devel list
Patch2: xmp-3.4.0-audacious-probe_for_tuple.patch

%description
The Extended Module Player is a modplayer for Unix-like systems that plays
over 80 mainstream and obscure module formats from Amiga, Atari, Acorn,
Apple IIgs and PC, including Protracker (MOD), Scream Tracker 3 (S3M), Fast
Tracker II (XM) and Impulse Tracker (IT) files.

%package -n audacious-plugin-%{name}
Summary: A xmp plugin for Audacious
Group: Applications/Multimedia
%if 0%{?fedora} > 13
%{?aud_plugin_dep}
%else
Requires: audacious
%endif

%description -n audacious-plugin-%{name}
The Extended Module Player is a modplayer for Unix-like systems that plays
over 80 mainstream and obscure module formats from Amiga, Atari, Acorn,
Apple IIgs and PC, including Protracker (MOD), Scream Tracker 3 (S3M), Fast
Tracker II (XM) and Impulse Tracker (IT) files.

This package contains the xmp plugin for the Audacious media player.

%package -n xmms-%{name}
Summary: A xmp plugin for XMMS
Group: Applications/Multimedia
Requires: xmms

%description -n xmms-%{name}
The Extended Module Player is a modplayer for Unix-like systems that plays
over 80 mainstream and obscure module formats from Amiga, Atari, Acorn,
Apple IIgs and PC, including Protracker (MOD), Scream Tracker 3 (S3M), Fast
Tracker II (XM) and Impulse Tracker (IT) files.

This package contains the xmp plugin for XMMS.


%prep
%if 0%{?fedora} > 13
# Enforce availability of the audacious(plugin-api) dependency.
%{!?aud_plugin_dep:echo 'No audacious(plugin-api) dependency!' && exit -1}
%endif

%setup -q
%patch0 -p1 -b .aud-api-3.1
%patch1 -p1 -b .aud-api-3.2
%patch2 -p1 -b .aud-probe_for_tuple
pushd docs
for file in ChangeLog CREDITS ; do
	iconv -f iso8859-1 -t utf8 -o $file.utf $file && touch -r $file $file.utf && mv $file.utf $file
done

%build
%configure \
  --enable-audacious-plugin \
  --enable-pulseaudio \
  --enable-xmms-plugin

%{__make} V=1 %{?_smp_mflags}

%install
rm -rf %{buildroot}
%{__make} install DESTDIR=%{buildroot}

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root)
%doc README docs/COPYING docs/README.* docs/ChangeLog docs/CREDITS
%config(noreplace) %{_sysconfdir}/*
%{_bindir}/*
%{_mandir}/man1/xmp.1*

%files -n audacious-plugin-%{name}
%defattr(-,root,root)
%{audacious_input_plugin_dir}/*

%files -n xmms-%{name}
%defattr(-,root,root)
%{xmms_input_plugin_dir}/*

%changelog
* Fri Jun 15 2012 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-8
- Fix untimely g_free(filename) in Audacious 3 plugin.

* Mon Jun  4 2012 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-7
- Fix undefined symbol corner-case for Audacious 3.2 API (#825937).

* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

* Mon Jan  2 2012 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-5
- Rebuild for Audacious 3.2-beta1 generic plugin API/ABI bump.
- Update Audacious 3.1 Preferences API patch for header changes.

* Sat Dec 24 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-4
- Rebuild for Audacious 3.2-alpha1 generic plugin API/ABI bump.

* Wed Oct 26 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-3
- Rebuild for Audacious 3.1-beta3 generic plugin API/ABI bump.

* Wed Oct 12 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.4.0-2
- Port to Audacious 3.1 Preferences API.
- Rebuild for Audacious 3.1-beta1 generic plugin API/ABI bump.
- Depend on audacious(plugin-api)%%{?_isa}.

* Wed Aug 10 2011 Dominik Mierzejewski <rpm@greysector.net> 3.4.0-1
- update to 3.4.0
- drop obsolete patches

* Thu Jul  7 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.3.0-8
- Rewrite the Audacious plugin for Audacious 3.0 Preferences Widgets.

* Sun Mar 27 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.3.0-7
- Rewrite the Audacious plugin for Audacious 2.5.
- Verbose build log with V=1 make.
- Update the audacious(plugin-api) stuff in the spec file for Audacious 2.5.

* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Fri Feb  4 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.3.0-5
- No build: wait for mass-rebuild in Rawhide.
- Enhance the audacious(plugin-api) stuff in the spec file.

* Fri Jan 28 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.3.0-4
- In audacious-plugin-xmp require a specific audacious(plugin-api).

* Mon Dec 13 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 3.3.0-3
- Rebuild for Audacious 2.4.2 generic plugin API/ABI bump.

* Thu Dec 09 2010 Dominik Mierzejewski <rpm@greysector.net> 3.3.0-2
- apply upstream patches to fix crash in audacious plugins (bug #660507)

* Sat Dec 04 2010 Dominik Mierzejewski <rpm@greysector.net> 3.3.0-1
- updated to 3.3.0
- drop obsolete patches

* Wed Jul 21 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 3.2.0-3
- Patch and rebuild for Audacious 2.4 beta1 generic plugin API/ABI bump.

* Thu Jul 15 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 3.2.0-2
- Rebuild for Audacious 2.4 alpha3 generic plugin API/ABI bump.

* Thu Jul 08 2010 Dominik Mierzejewski <rpm@greysector.net> 3.2.0-1
- updated to 3.2.0
- fixed compilation on rawhide

* Sun Jan 17 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 3.1.0-2
- Rebuild for audacious.pc --libs changes.

* Thu Jan 07 2010 Dominik Mierzejewski <rpm@greysector.net> 3.1.0-1
- updated to 3.1.0
- enabled parallel build
- dropped obsolete patches
- built with pulseaudio output support

* Thu Dec 31 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.7.1-2
- fix FTBFS (#539061), Audacious 2.2 iplugin API change
- fix Audacious plugin dialogs

* Mon Sep 14 2009 Dominik Mierzejewski <rpm@greysector.net> 2.7.1-1
- updated to 2.7.1
- dropped obsolete patch
- fixes CVE-2007-6731 (rhbz#523138) and CVE-2007-6732 (rhbz#523147)

* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Mon Jul 20 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.5.1-7
- patch further for Audacious 2, because the bmp_cfg_* symbols are gone
  since Audacious 1.5 already

* Sun Jul 19 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.5.1-6
- patch for Audacious 2 (xmp-2.5.1-audacious2.patch)

* Tue Jun 16 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.5.1-5
- rebuild for new libmowgli SONAME (audacious-plugin-xmp depends on it
  indirectly because of audacious-devel pkgconfig dep-chain)

* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Mon Oct 13 2008 Dominik Mierzejewski <rpm@greysector.net> 2.5.1-3
- add a script to create the free tarball
- drop workaround for missing audacious-devel Requires:

* Mon Jul 07 2008 Dominik Mierzejewski <rpm@greysector.net> 2.5.1-2
- repackaged source tarball without the OCL-licensed file

* Wed Jun 25 2008 Dominik Mierzejewski <rpm@greysector.net> 2.5.1-1
- initial build based on upstream spec
- disabled stripping upon install
- renamed player plugins to playername(-plugin)-xmp
- worked around missing BRs in audacious-devel in rawhide
- converted non-UTF8 docs