Blob Blame History Raw
%define pkgname font-utils
# FIXME: Upstream tarball is 0.99.0, which would require
# us to add an "Epoch: 1" to this package in order for rpm to upgrade from
# the FC4 (and earlier) monolithic xorg-x11-xfs-6.8.x rpm package.  Since
# it is currently unknown what the final upstream tarball version is likely
# to be called, I am avoiding adding Epoch, and instead using a 6.99.99.x
# version number for the time being.  This allows us to make sure xfs will
# upgrade from older releases to the new release, allows us to avoid adding
# an Epoch tag possibly unnecessarily - as Epoch is permanent and very evil.
# If upstream later names it "xfs-7.0", then we bump the version to that,
# and everything just works.
%define upstreamversion 0.99.0

Summary: X.Org X11 font utilities
Name: xorg-x11-%{pkgname}
Version: 6.99.99.0
Release: 1
License: MIT/X11
Group: User Interface/X
URL: http://www.x.org
Source0: http://xorg.freedesktop.org/X11R7.0-RC0/everything/bdftopcf-0.99.0.tar.bz2
Source1: http://xorg.freedesktop.org/X11R7.0-RC0/everything/fonttosfnt-0.99.0.tar.bz2
Source2: http://xorg.freedesktop.org/X11R7.0-RC0/everything/mkfontdir-0.99.0.tar.bz2
Source3: http://xorg.freedesktop.org/X11R7.0-RC0/everything/mkfontscale-0.99.0.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

# xorg-x11-libXfont-devel needed for bdftopcf
BuildRequires: libXfont-devel
# xorg-x11-libX11-devel needed for fonttosfnt
BuildRequires: libX11-devel
# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
BuildRequires: libfontenc-devel
# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
BuildRequires: freetype-devel
# zlib-devel needed for bdftopcf
BuildRequires: zlib-devel
# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
# from it directly.
BuildRequires: xorg-x11-proto-devel

Provides: %{pkgname}
Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale
# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
# is needed for upgrades to work properly from OS releases that had XFree86
Obsoletes: XFree86-font-utils
# NOTE: XFree86 package used to contain bdftopcf, so this is needed for
# upgrades to work.  It also contained mkfontdir/mkfontscale at one point,
# so we just Conflict without a version specification.
Conflicts: XFree86
# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
# xorg-x11-font-utils in 6.7.99.903-3
Conflicts: xorg-x11-base-fonts <= 6.7.99.903-3
# FIXME: modular X seems to be abscent of ucs2any so far, so I'll update this
# when I find it later... -- mharris
# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
#Conflicts: xorg-x11-tools <= 6.7.99.903-3

%description
X.Org X11 font utilities required for font installation, conversion,
and generation.

%prep
%setup -q -c %{name}-%{version} -a1 -a2 -a3

%build
# Build bdftopcf
{
   pushd bdftopcf-%{upstreamversion}
   %configure
   make
   popd
}
# Build fonttosfnt
{
   pushd fonttosfnt-%{upstreamversion}
   %configure
   make
   popd
}
# Build mkfontdir
{
   pushd mkfontdir-%{upstreamversion}
   %configure
   make
   popd
}
# Build mkfontscale
{
   pushd mkfontscale-%{upstreamversion}
   %configure
   make
   popd
}

%install
rm -rf $RPM_BUILD_ROOT
# Build bdftopcf
{
   pushd bdftopcf-%{upstreamversion}
   %makeinstall
   popd
}
# Build fonttosfnt
{
   pushd fonttosfnt-%{upstreamversion}
   %makeinstall
   popd
}
# Build mkfontdir
{
   pushd mkfontdir-%{upstreamversion}
   %makeinstall
   popd
}
# Build mkfontscale
{
   pushd mkfontscale-%{upstreamversion}
   %makeinstall
   popd
}
# FIXME: Move manpages to correct man section and rename them.  This should
# get submitted as a bug upstream for fonttosfnt.
{
   echo "FIXME: Upstream fonttosfnt manpages install to incorrect location"
   #mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
   for manpage in fonttosfnt ; do
      mv $RPM_BUILD_ROOT%{_mandir}/manm/$manpage.man $RPM_BUILD_ROOT%{_mandir}/man1/$manpage.1
   done
   rmdir $RPM_BUILD_ROOT%{_mandir}/manm
}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc
%dir %{_bindir}
%{_bindir}/bdftopcf
%{_bindir}/fonttosfnt
%{_bindir}/mkfontdir
%{_bindir}/mkfontscale
%dir %{_mandir}
%dir %{_mandir}/man1
%{_mandir}/man1/bdftopcf.1*
%{_mandir}/man1/mkfontdir.1*
%{_mandir}/man1/mkfontscale.1*
# FIXME: Upstream tarball installs this into "manm" dir, with .man suffix
%{_mandir}/man1/fonttosfnt.1*

######################################################################
# FIXME: monolithic xorg-x11-font-utils file manifest, copied here for
# ease of developmental comparison, until the package is complete and
# finalized.  I'll remove this once it's no longer useful.  -- mharris
#%files font-utils
#%defattr(-,root,root)
#%{_x11bindir}/bdftopcf
#%{_x11mandir}/man1/bdftopcf.1*
#%{_x11bindir}/bdftruncate
#%{_x11mandir}/man1/bdftruncate.1*
##%{_x11bindir}/fonttosfnt
##%{_x11mandir}/man1/fonttosfnt.1*
#%if %{with_fontconfig}
#%{_x11bindir}/fc-cache
#%{_x11bindir}/fc-list
#%{_x11mandir}/man1/fc-cache.1*
#%{_x11mandir}/man1/fc-list.1*
#%endif
#%{_x11bindir}/mkfontdir
#%{_x11mandir}/man1/mkfontdir.1*
#%{_x11bindir}/mkfontscale
#%{_x11mandir}/man1/mkfontscale.1*
## The 'util' subdir is used by ucs2any, mkfontdir et al.
#%dir %{_x11fontdir}/util
#%{_x11fontdir}/util/*
## FIXME: ucs2any should be moved to %{name}-font-utils
#%{_x11bindir}/ucs2any
## FIXME: ucs2any should be moved to font-utils subpackage
#%{_x11mandir}/man1/ucs2any.1*

#%dir %{_bindir}
#%{_bindir}/twm
#%dir %{_mandir}
#%dir %{_mandir}/man1
#%{_mandir}/man1/twm.1*
# FIXME: modular build is not installing the twm config currently, find out
# why and fix it.
#%dir %{_sysconfdir}
#%dir %{_sysconfdir}/X11/twm
#%config %{_sysconfdir}/X11/twm/system.twmrc
######################################################################

%changelog
* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
- Initial build.