Blob Blame History Raw
%define pkgname utils

Summary: X.Org X11 X client utilities
Name: xorg-x11-%{pkgname}
Version: 0.99.2
#Release: 1.RC2.0
Release: 1
License: MIT/X11
Group: User Interface/X
URL: http://www.x.org

Source0:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xdpyinfo-0.99.1.tar.bz2
Source1:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xdriinfo-0.99.1.tar.bz2
Source2:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xev-0.99.1.tar.bz2
Source3:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xfd-0.99.1.tar.bz2
Source4:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xfontsel-0.99.1.tar.bz2
Source5:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xlsatoms-0.99.1.tar.bz2
Source6:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xlsclients-0.99.1.tar.bz2
Source7:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xlsfonts-0.99.1.tar.bz2
Source8:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xprop-0.99.1.tar.bz2
Source9:  http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xvinfo-0.99.1.tar.bz2
Source10: http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything/xwininfo-0.99.1.tar.bz2

%define applist xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo

BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildRequires: pkgconfig
# xdriinfo requires libGL-devel
BuildRequires: libGL-devel

Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo

%description
A collection of client utilities which can be used to query the X server
for various information, view and select fonts, etc.

%prep
%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10

%build
# Build all apps
{
   for app in * ; do
      pushd $app
      %configure
      make
      popd
   done
}

%install
rm -rf $RPM_BUILD_ROOT
# Install all apps
{
   for app in * ; do
      pushd $app
      make install DESTDIR=$RPM_BUILD_ROOT
      popd
   done
}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc
%dir %{_bindir}
%{_bindir}/xdpyinfo
%{_bindir}/xdriinfo
%{_bindir}/xev
%{_bindir}/xfd
%{_bindir}/xfontsel
%{_bindir}/xlsatoms
%{_bindir}/xlsclients
%{_bindir}/xlsfonts
%{_bindir}/xprop
%{_bindir}/xvinfo
%{_bindir}/xwininfo
# FIXME: These files should all be moved to /usr/share as they're arch
# independent data.
%dir %{_libdir}
%dir %{_libdir}/X11
%dir %{_libdir}/X11/app-defaults
%{_libdir}/X11/app-defaults/XFontSel
%{_libdir}/X11/app-defaults/Xfd
# FIXME: End of files from above that should be in /usr/share.
%dir %{_mandir}
%dir %{_mandir}/man1x
%{_mandir}/man1x/xdpyinfo.1x.gz
%{_mandir}/man1x/xdriinfo.1x.gz
%{_mandir}/man1x/xev.1x.gz
%{_mandir}/man1x/xfd.1x.gz
%{_mandir}/man1x/xfontsel.1x.gz
%{_mandir}/man1x/xlsatoms.1x.gz
%{_mandir}/man1x/xlsclients.1x.gz
%{_mandir}/man1x/xlsfonts.1x.gz
%{_mandir}/man1x/xprop.1x.gz
%{_mandir}/man1x/xvinfo.1x.gz
%{_mandir}/man1x/xwininfo.1x.gz

%changelog
* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
- Initial build, with all apps taken from X11R7 RC2
- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
  some packages.